Configuration de base sous Vyatta

Vyatta Core Software

Vyatta core est une distribution orientée routage qui centralise les flux réseaux sur une VM.
Elle implémente donc une composante du Software-Defined Networking (SDN).
Alors, oublier les distributions de type smoothwall, pfsense, ou ipcop totalement inadaptée pour la virtualisation, car aucune composante SDN n'est présente dans celle ci.
Aussi, l'interface web n'est pas disponible  dans Vyatta Core software..
Il existe deux versions, et voici les  différences entre celles-ci : disponible ici

Débuter avec la configuration de base sous Vyatta
 

Exemple des étapes de base :

  1. Configuration des interfaces (eth0, eth1).
  2. Ajout d'un" forward" et" resolv DNS".
  3. Mise en place de route statique.
  4. Création d'un Pool DHCP pour le réseau local.
  5. Création d'une règle pare-feu dans notre LAN.
  6. Connecter le réseau local à internet (NAT).

Les commandes utiles :

Pour passer en mode configuration sous Vyatta:

configure

Pour sauvegarder les modifications  :

commit

Pour sauvegarder les modifications dans un fichier  :

save

Pour connaitre les autres commandes de Vyatta : touche de tabulation.

Configuration des interfaces

set interfaces ethernet eth0 address X.X.X.X/X
set interfaces ethernet eth0 description reseau_internet

set interfaces ethernet eth1 address 192.168.1.1/24
set interfaces ethernet eth1 description reseau_local

Ajout de résolution DNS

set system name-server 8.8.8.8

Ajout de transmission DNS (optionnel)

set service dns forwarding listen-on eth0
set service dns forwarding system

Mise en place de route statique (optionnel)

set protocols static interface-route X.X.X.X/X next-hop-interface eth0

Attention cette commande fait particulièrement parler d'elle sur le réseau d'OVH.
Elle provoque des tempêtes ARP. Ceci est un bug connu sur le forum de Vyatta.
La solution temporaire proposée est d’annuler cette commande , et ensuite de revenir aux commandes classiques d’une Debian (route, ifconfig etc)

Pour annuler la commande :

delete protocols static interface-route X.X.X.X/X next-hop-interface eth0

Mise en place de route statique OVH (optionnel)

Pour cela il faut sortir de la configuration de Vyatta et faire les manipulations en root.

route add X.X.X.254 dev eth0
route add default gw X.X.X.254

Pool DHCP pour réseau local

set service dhcp-server shared-network-name pool_lan1
set service dhcp-server shared-network-name pool_lan1 subnet 192.168.1.0/24
set service dhcp-server shared-network-name pool_lan1 subnet 192.168.1.0/24 start 192.168.1.10 stop 192.168.1.15
set service dhcp-server shared-network-name pool_lan1 subnet 192.168.1.0/24 default-router 192.168.1.1
set service dhcp-server shared-network-name pool_lan1 subnet 192.168.1.0/24 dns-server 8.8.8.8

Création d'une règle pare-feu

set firewall name reseau_internet 
set firewall name reseau_internet rule 10 action accept
set firewall name reseau_internet rule 10 state established enable

Application de la règle pare-feu à l'interface

set interfaces ethernet eth0 firewall in name reseau_internet
set interfaces ethernet eth0 firewall local name reseau_internet

Connecter le réseau local à internet (NAT)

set nat source rule 10 source address 192.168.1.0/24
set nat source rule 10 outbound-interface eth0
set nat source rule 10 translation address masquerade

Votre réseau est désormais fonctionnel, la configuration de base sous Vyatta est terminée !
Pour ceux qui ont encore du mal après cette introduction n'hésitez pas à me contacter.

Commentaires